Launching VarSeq

When you launch VarSeq you may encounter a few dialogs before a project opens up or is created. These dialogs are outlined below.

Login and Register Dialog

If you are opening VarSeq for the first time on a machine (or for the first time period) the first dialog you will see on launching VarSeq is the dialog to login or register your VarSeq license. You may also see this dialog if you choose not to have your credentials saved or have previously logged out of VarSeq.

Login

If you have an existing Golden Helix account with a valid VarSeq license, enter in your email address and password. You can optionally uncheck the “Stay logged in” option to have VarSeq not store credentials locally and require logging in again after relaunching the software. After the account information is filled in, click Log In.

Log In Page

Log in or register for a Golden Helix account to access VarSeq

Register

If you do not have an existing Golden Helix account, click on the Register tab and fill out the registration form. Once the required fields have been filled in and the license agreement has been accepted, the Register & Log In button will become active. You can optionally uncheck the “Stay logged in” option to have VarSeq not store credentials locally and require logging in again after relaunching the software.

The Golden Helix account will also be the credentials used to log into the answers.goldenhelix.com community site.

Activate a License Key

Once logged in, if it is the first time logging in on a particular computer, you will need to activate a license key. Either click on Activate License Key in the lower right hand corner of the Welcome Screen, or go to Help > Activate a VarSeq License Key. Type or paste in the provided license key and press Verify. Once the key has been verified, if there are available activations the Activate button will become active. To activate VarSeq for the particular user account and machine click Activate.

VarSeq can be used without an active license key. This is called “Viewer Mode”. See VarSeq Viewer for more information.

VarSeq Viewer

VarSeq Viewer is available to make sharing projects and results easy for collaboration and data sharing. The viewer can open any existing project, allows for modification of existing filter chains and tables. Tables can be exported to VCF, text and Excel XLSX formats. However, new projects cannot be created, new annotation sources cannot be added to an existing project, and any modifications cannot be saved.

Adjusting Proxy Settings

To allow VarSeq to communicate with our data servers, if your institution has a proxy server, the proxy settings need to be set appropriately. Please request assistance from your IT department if needed for the proxy settings.

To change the proxy settings, from the Login and Register dialog, go to Tools > Proxy Settings.... Adjust the proxy settings as required and click OK.

If you have already logged in and are in a project, you can still adjust the proxy settings from Tools > Proxy Settings. You may need to restart the program for all uses of the network to properly pick up the new settings.

Create a New Project

To create a new project, click on Create New Project from the Welcome Screen. A list of existing project templates will be displayed. Documentation for all of the templates is displayed to the right of the list.

Select a template, choose the genome assembly. Note, if the template assumes a particular genome assembly choosing a different genome assembly can result in errors if the template relies on genome assembly specific annotation sources.

Enter in a project name and location to save the project, and click OK.

New Project

Create a new project from an existing template or from an empty template

Download Reference Sequence Question

If a reference sequence for the genome selected exists on the public data annotations repository, and the reference sequence is not detected in the User Annotations folders, a question dialog will appear asking whether or not the reference sequence should be downloaded. See Download reference sequence question.

Download Reference

Download reference sequence question

To prevent this dialog from reappearing for the specific genome, check the “Don’t ask about this genome again” box at the bottom of the dialog.

Otherwise, to download the reference sequence in a background process, click Yes. To not download the reference sequence, click No.

For more information on downloading annotation sources see Download Window.