Understanding the Interface and Workflow

Golden Helix SVS includes a variety of tools to help you keep track of, manipulate, analyze, and visualize your data. Understanding how these tools inter-operate will help you become more proficient with the software and maximize your results.

General Genetic Association Analysis Workflow

There is a myriad of approaches to genetic association analysis. Which steps you perform and when depends largely on the type of study you’re conducting (e.g. population vs. family), the types of variables you are analyzing (e.g. SNPs vs. CNVs), the scale of your study (e.g. candidate gene vs. whole genome), and the scientific questions you hope to answer. Outlined below is a general workflow for genetic association analysis using Golden Helix SVS.

Create a new project
Create a new project.
Import data
Import genetic, phenotype, pedigree (if doing family analysis), and any other variables into your project.
Prepare data for analysis
Perform any necessary quality control, transformations, recoding, filtering, and principal component analysis on your data and then combine all ‘cleaned’ data into a single spreadsheet.
Import and apply genetic marker map
Import a genetic marker map corresponding to the type of genetic data you are working with and apply it to the combined spreadsheet containing genetic data.
Perform association analysis
Perform the appropriate association test(s) corresponding to your data and study type.
Visualize results
Generate a series of plots to visualize your results.

Interface Overview

Welcome Screen
The welcome screen appears when you do not have a project open. From here, you can open an existing project, create a new project, download example projects, set options for all new projects, access valuable community resources to help you learn how to use the software more effectively, and more. The welcome screen also displays relevant license information, the package and components you have activated and recent support bulletins to notify users of software updates, available add-on scripts as well as known bugs and bug fixes.
Project Navigator
When a project is open, the Project Navigator is the primary screen. It helps keep track of all your data, analyses and results. It also provides the means for acquiring files, accessing your data and plots and setting options for the currently open project.
Python Shell
Python is a fully programmable scripting language. The Python shell, which can be accessed from the welcome screen or the project navigator, is used to perform operations available within the graphical user interface (GUI) in a command line environment.
Python Editor
The Python editor provides an intuitive interface for writing and editing entire scripts.
Spreadsheets
Data imported into a project is stored within a spreadsheet. Spreadsheets that do not have a marker map applied to them are denoted by a blue icon in the project navigator. Spreadsheets with a genetic marker map applied are denoted with a green icon. Spreadsheets enable you to view your data, results and genetic marker map information (if a genetic marker map has been applied) within a table format. Most standard analyses and quality assurance measures are performed from a spreadsheet. Spreadsheets also provide the means for launching the integrated visualization analytic navigator to generate graphs.
Spreadsheet Editor
The spreadsheet editor enables you to manipulate your data and save it as a new spreadsheet.
GenomeBrowse
GenomeBrowse is a very powerful tool for generating plots from various genomic data sources.
Plot Viewer
Generic uniform scale plots are visualized in the plot viewer. Histograms, XY Scatter Plots, as well as uniform scale versions of some genomic plots can be visualized in the plot viewer.

Project Navigator

Once a project has been created or opened, the Project Navigator appears. This interface displays a single project at a time. The Project Navigator has a similar menu and tool bar as the welcome screen, but the window is split into three panes, and the additional Import menu is available. The larger pane on the left side is the Project Navigator Window. The two panes on the right side are the Node Change Log and the User Notes. A project navigator is displayed in SVS Project Navigator.

projNav

SVS Project Navigator

Project Navigator Window

The Project Navigator window contains a dynamic tree of Navigator Window Nodes, which are created whenever data is imported, spreadsheets or plots are created, or whenever one of the analysis tools is used.

Navigator Window Nodes
Importing a dataset creates two new Navigator Window Nodes under the Project Node: one for the dataset and another for the Spreadsheet Viewer. See Importing Your Data Into A Project on importing data into a SVS project.

The Navigator Window Nodes are displayed showing the parent/child relationship of the nodes. Subtrees of a Navigator Window Node can be expanded or collapsed by clicking on the + or - next to the node. If there are no signs present, there are no subtrees for that node.

The ID numbers to the right of the node names indicate the ID number of that particular node. The ID number never changes even if the node is renamed or other nodes are deleted.

The Linked To column specifies which nodes are linked to each other. When selecting a node linked to other nodes, all nodes linked together are highlighted in blue, and the current node is highlighted in gray.

Managing Navigator Window Nodes
Since the default naming scheme is fairly non-descriptive in some instances, it may be helpful to rename the nodes to more descriptive names to help you find your data faster. A node can be renamed by right-clicking on the node or left-clicking and holding for a few seconds.

A node can be deleted as long as there are no other nodes dependent on it. If a parent node has children nodes with no other dependent nodes, the parent node can be deleted, but all children nodes will also be deleted. If a dataset has only one spreadsheet attached to it, deleting either the spreadsheet or the dataset will delete both nodes. A dataset cannot exist in the project without a corresponding spreadsheet viewer.

A node can be opened by either a double left-click or by right-clicking and selecting Open Viewer.

A dataset can be created for a subset or child spreadsheet by right-clicking and selecting Create Top Level Spreadsheet. This can be used to remove dependencies associated with a navigator window node to allow for the deletion of the parent node. (See Create Top-Level Spreadsheet.)

Node Change Log Window

The Node Change Log logs and displays messages generated by the system for each Navigator Window Node. Each node has an initial log entry with its unique ID, date and time the node was created, and how the node was created (if not the result of a simple import). The log shows all messages associated with the currently highlighted Navigator Window Node. If a node is deleted, all of the associated log messages are also deleted.

User Notes Window

The User Notes window can be a valuable documentation tool as well as the repository for information needed to create project reports. The User Notes window can be edited by clicking in the text box below the User Notes header. The information displayed in the User Notes window is deleted if the associated Navigator Node is deleted.

Customizing the Project Navigator

You can customize the Project Navigator by resizing and moving the Node Change Log or User Notes panes around, moving either of these two panes moves the Project Navigator Window as well. To move a pane left click and drag the pane’s title bar to the location you want. To resize the panes left click and drag the vertical or horizontal divider between the panes you want to resize.

File Menu

  • New Project

    Creates a new project file. If you have a project open and have made changes to it since you last manually saved it, you will be asked whether you want to save or discard your changes.

  • Open Project

    Lets you open an existing project file. If you have a project open and have made changes to it since you last manually saved it, you will be asked whether you want to save or discard your changes.

  • Save Project

    Every operation you perform in SVS is auto-saved upon completion. By choosing this option you can manually save your project at a specific point, which enables you to discard auto-saved changes if needed and revert your project back to the point at which you last manually saved it.

  • Save Copy of Project

    Leads you through saving a copy of the project in its current auto-saved state to a location you specify. If you have a project open and have made changes to it since you last manually saved it (see Save Project above), you will asked whether you want to save or discard your changes.

  • Close Project

    If you try to close the project without saving the recent changes you will be asked whether you want to save the project (keeping the auto-saved version) or discard the changes (keeping the manually saved version).

  • Clean and Compact Project

    This option removes temporary files and clears the cache. It is recommended that you run this operation before sending large projects to another user.

  • Project Info

    This dialog displays all of the properties of the current project including the name, project location, size, origination date and time, and date and time of the last save.

  • Recent Project Files

    Lists up to the last eight projects in the order they were opened, with the most recent at the top of the list. Clicking on a project file in the list will open that project.

  • Quit

    Closes down the application.

  • Log out (User Name) Closes current project and logs out the current user. If the project has recent changes you will be prompted to save.

Tools Menu

  • Current Project’s Options

    Sets defaults for the project. Also allows a password to be set for the project.

  • Proxy Settings...

    Allows user to adjust proxy setting for SVS.

  • View Project Log

    The node change log messages are displayed in a text box either in Navigator Window Node order or in chronological order.

  • Go To Node...

    Allows the user to select or enter in a node id number and jump to that location in the project navigator.

  • Manage Genome Assemblies

    Genome assemblies contain information about the number and size of the chromosomes for a particular species and build. Genome assemblies can be created or viewed through this dialog.

See also

For more information about genome assemblies, see Genome Assemblies.

  • Manage Data Sources

    Data sources contain information about genes, coding regions, read alignments, and variant calls, etc. for a particular species and build. Sources can be viewed in GenomeBrowse.

See also

For more information about annotation tracks, see The Data Source Library.

  • Manage Marker Maps

    Genetic marker maps are files containing distance data for individual genetic markers relative to some origin, as well as other data relative to the markers. They can be applied to spreadsheets with genetic data.

See also

For more information about genetic marker maps, see Genetic Marker Maps and Affymetrix Library Files.

  • Run Python Script

    You can run Python scripts saved as *.py files.

See also

For more information about Python scripts, see Running Scripts.

  • Open Python Editor

    The Python Editor is a powerful interface for writing and editing Python scripts.

See also

For more information about the Python editor, see The Python Editor Window.

  • Open Python Shell

    You can use the features of Golden Helix SVS in a command line scripting mode via a Python shell.

See also

For more information about the Python shell see The Python Shell Window.

  • New GenomeBrowse Window

    Creates a new empty GenomeBrowse window for plotting data, see GenomeBrowse: The Genomic Scale Data Visualization Tool.

  • Open Folder

    • AppData Folder: Launches (or puts into focus, if one already exists) a file browser window from your operating system which is open to the root directory of your AppData. This folder can be used to access genome assemblies, marker maps, annotations and the UserScripts folder.
    • Project Folder: Launches (or puts into focus, if one already exists) a file browser window from your operating system which is open to the root directory of the open project. This folder will contain all of the files used to create the project.
    • SVS Install Folder: Launches (or puts into focus, if one already exists) a file browser window from your operating system which is open to the root directory of your SVS install folder.
    • User Scripts Folder: Launches (or puts into focus, if one already exists) a file browser window from your operating system which is open to the root directory of your user scripts. You may then use this window to conveniently open a Python script using a text editor of your choice.
    • Marker Maps Folder: Launches (or puts into focus, if one already exists) a file browser window from your operating system which is open to the root directory of your marker maps. You may then use this window to view the marker maps in your local directory.
    • Genome Assemblies Folder: Launches (or puts into focus, if one already exists) a file browser window from your operating system which is open to the root directory of your genome assemblies. You may then use this window to view the genome assemblies in your local directory.
    • User Annotations Folder: Launches (or puts into focus, if one already exists) a file browser window from your operating system which is open to the root directory of your user annotations. You may then use this window to view the annotation sources in your local directory.
    • Imputation Reference Panels Folder: Launches (or puts into focus, if one already exists) a file browser window from your operating system which is open to the root directory of your reference panel folder. You may then use this window to view the reference panels that have either been download from the Golden Helix server or created from within SVS.
  • Pre-Study Power Calculation

    Uses the PBAT approach to analytical power calculations for FBATs by [Lange2002a], [Lange2002b], and [Lange2002c]. They allow the user to assess the power of family-based association tests (FBATs) for a large variety of different designs.

See also

See Pre-Study Power Calculation for help with this feature.

  • SNP Consensus and Concordance

    This feature compares genotypes over several markers and subjects, either in one or several spreadsheets. Consensus genotypes and concordance rates are reported in four output spreadsheets; Concordance by Subject, Concordance by SNP, Discordant Genotypes and Consensus Genotypes.

See also

See SNP Consensus and Concordance for more information.

  • Update Software

    This option is only available from the Program Welcome Screen. To update the software, close the open project and then select this option.

  • Find Spreadsheet Node

    This option allows the user to enter in a string to search all the spreadsheet node names and displays a list dialog containing all spreadsheet nodes containing the string. Allows the user to select a node and open it without having to scroll to that spreadsheet node.

  • Build Sample Collated Spreadsheet

    This tool takes several column mapped spreadsheets and creates one collated spreadsheet. Each row from each spreadsheet is placed in a column of the resulting spreadsheet with columns for the same sample placed adjacent in the new spreadsheet.

    See also

    See Build Sample Collated Spreadsheet for more information.

  • Compare Variants Across Several Spreadsheets

    This tool compares variants across several spreadsheets and computes the number of variants shared over all possible spreadsheet combinations. In the case when two or three spreadsheets are given as input, a Venn diagram is created.

    See also

    See Compare Variants Across Several Spreadsheets for more information.

  • Perform Meta-Analysis

    This tool performs a meta-analysis of results taken from two or more studies, each study containing individual GWAS or other analysis results for multiple markers. All results for each individual marker are meta-analyzed across all studies for which the marker has valid results. Each study’s results should be contained in a separate spreadsheet (or spreadsheet tab), and may either have been output from a Golden Helix SVS analysis feature or have been imported into Golden Helix SVS from external data.

    See also

    See Meta-Analysis for more information.

Import Menu

Several types of data formats can be imported into Golden Helix SVS for use in analysis.

See Importing Your Data Into A Project for information on these file formats.

Please see Illumina for instructions on how to import data directly from Illumina text files, and see Affymetrix Files for instructions on how to import data from Affymetrix formats.

  • Text

    Text files in either a CSV or TXT format can be imported using this option. Any text file saved with an appropriate text delimiter can be imported.

  • Third Party

    Third party software can be imported into Golden Helix SVS for use in plotting or analysis. Numerous data types can be imported using this feature.

Note

The new Microsoft Excel XLSX format is now supported for import and export in the Windows versions of SVS but is not currently available for Linux or Mac.

  • PED/TPED/BED

    The two file PED/MAP format often containing both family-based and regular genotype data popularized by PLINK can be imported into Golden Helix SVS. Both the plain text PED/MAP files as well as the optimized binary PED or BED files (which should have correlating BIM/FAM files) can be imported using this option. Transposed pedigree files in the TPED/TFAM formats can also be imported into Golden Helix SVS.

  • Golden Helix DSF

    DSF files saved from a Golden Helix SVS project retain marker maps and on import save the marker map to the project as well as to the Genetic Marker Map’s folder if desired.

  • Golden Helix Legacy GHD

    GHD files saved from a Golden Helix SVS project do not retain maker map information, but GHD files can be opened in earlier versions of SVS prior to version 7.0.0.

  • Public Data

    Public data, such as HapMap data, can be downloaded and imported directly into Golden Helix SVS.

  • Affymetrix

    Five Affymetrix file types can be imported into SVS for analysis; these are the CHP, CEL, CNT, CNCHP, and CYCHP file formats. Affymetrix DMET reports can be imported into SVS, as well.

  • Illumina

    A submenu containing import tools for Illumina Data. Possible file types include files created using the Illumina Bead/GenomeStudio plug-in, Final Reports from one or more files, Matrix Text files, and iControlDB data.

  • Agilent Files

    Agilent copy number data text files can be imported into the project using this option.

  • NimbleGen Data Summary Files

    NimbleGen data summary *segMNT.txt text files can be imported into the project using this option.

  • Family Pedigree

    SVS provides tools for the design and analysis of family-based association studies through the capabilities of the PBAT software package developed by Dr. Christoph Lange of Harvard University. http://www.hsph.harvard.edu/faculty/christoph-lange/

See also

Please see Importing Family Pedigree Data for instructions on how to import pedigree and phenotype data.

  • Import VCFs and Variant Files

    Variant Call Format (VCF), 23andMe text files as well as other variant type data can be imported into multiple spreadsheets with this option.

    See also

    Please see Import VCFs and Variant Files for further details.

  • Import Complete Genomics Var Files Complete Genomics VAR files can be imported with this option.

    See also

    See Import Complete Genomics Data for more information.

  • Import Impute2 GWAS Files Impute2 *.gen and *.sample files can be imported with this option.

    See also

    See Impute2 GWAS Files for more information.

  • HapMap

    This function imports user-specified text files with extensions .hmp, .txt, or .csv from the HapMap project. Multiple HapMap files cannot be merged together with this script.

  • MACH Output

    Three MACH file outputs can be imported into SVS for analysis using this option: mldose, mlgeno, and mlinfo.

  • RNA-Seq Tabularized Quantification This function imports the tabularized quantification data from pipeline.goldenhelix.com.

See also

See RNA-Seq Tabularized Quantification for more information.

Download Menu

  • Download Window

    Lists recent downloads and downloads currently in progress. See Download Window for more information.

  • Marker Maps

    Marker Maps for several Affymetrix and Illumina arrays are available for download using this link. The annotation files are hosted on our data repository and Affymetrix files are also available through NetAffx. All downloaded maps will be available in the AppData folder.

  • Example Projects

    Completed tutorial projects can be downloaded using this link and used for testing or exploring the software.

  • Public Data

    Data needed for testing can be downloaded and saved in a specified directory using this link.

  • Imputation Data

    Available imputation reference panel data, including subsets of the phased genotype data provided from BEAGLE. Data is designed to be used with the Genotype Imputation tool, see Genotype Imputation.

  • Affymetrix Annotations

    Affymetrix annotation files can be downloaded directly from NetAffx by using this option. They can also be downloaded by going to Tools > Genetic Marker Maps and clicking on the Download Affymetrix Annotations button.

  • Affymetrix Library Files

    Affymetrix library files are needed to complete certain Affymetrix-specific operations, such as importing CHP and CEL files. These files can be downloaded to a specified directory using this option.

    For more information about Affymetrix library files, see Genetic Marker Maps and Affymetrix Library Files.

Resources Menu

A variety of tools are available to help you become more proficient with the software and extend the utility of your data.

  • Add-on Scripts:

    Python scripts written by Golden Helix and its customers can be downloaded and used to enhance the usability of the software. Enhancements range from simple data transformations to completely automated workflows and integration with other packages.

  • Webcasts:

    Golden Helix hosts webcasts periodically presented by its staff and customers to discuss new methods, new products and relevant research within the community.

  • Tutorials:

    More in depth tutorials are available on our website covering a variety of topics, ranging from basic getting started operations to more complex analysis workflows.

  • Blog:

    A blog created by Golden Helix that seeks to inform our customers and the genetic research community as a whole on the latest in analysis methods, best practices, and the future of the industry.

Window Menu

Window management is available from the Window menu on the project navigator. If there are windows open either plot windows, GenomeBrowse windows, or spreadsheets there will be options to close all windows, close spreadsheets, or close plots. The list of open windows will also be included in the dialog, selecting a window in the menu will switch the focus to that window and bring it to the top of all open windows.

Help Menu

  • SVS Manual

    Opens the internal manual.

  • SVS PDF Manual

    Opens the PDF version of the manual.

  • Edit User Profile

    Opens dialog to allow user to change name, profile information, email and password used to login to Golden Helix products.

  • Activate a SVS License Key

    Dialog used to activate the licensed version of SVS. See Login and Register Dialog for more information.

  • About SVS

    Provides information regarding the version of the software you have installed and important license information, which is helpful for troubleshooting, updating your license, adding components, etc.

Tool Bar

The Tool bar has a row of icons that provide quick access to some of the menu options. A description of the Tool bar icon appears when you place the cursor over the icon. You can perform the following tasks using the Tool bar icons:

  • Create a new project
  • Open a project
  • Close current project
  • Save project
  • Access program or project options
  • Manage Genome Assemblies
  • Manage Data Sources
  • Manage Genetic Marker Maps
  • Open a Python shell
  • Open a new GenomeBrowse Window
  • Open the Download Window
  • Give feedback
  • Open the SVS Manual

Node Menu

Right-clicking on any node within an SVS project opens a menu with options for node-specific actions. The available actions are listed below.

  • Rename Node: Set the node name to a given string.

  • Delete Node: Delete the node and all child nodes if applicable.

  • Open Viewer: Open the spreadsheet or plot.

  • Create Top Level Spreadsheet: Create new top level node for spreadsheet at

    bottom of Project Navigator. See Create Top-Level Spreadsheet.

  • Collapse all Children Nodes: Hides all children nodes (and all of their children nodes) from view. The same action can be accomplished by clicking on the arrow to the left of the expanded node as well as the arrows left of all expanded children nodes.

  • Expand all Children Nodes: Performs the opposite action of Collapse all Children Nodes.

Node Tagging

Spreadsheets or plots that have a special purpose, or should stand out among other nodes for any reason, can be set to have a color tag. Color tags can be green, blue, yellow or red. Setting a color tag results in a colored square appearing between the node title and node icon from a project navigator view.

Nodes that have user notes attached receive a distinct tag, since any node that was given special consideration by the user is considered inherently special. If the node does not have a color set prior to user annotation, a white tag will appear superimposed with an N. If the node already has a color tag set, the colored tag will be superimposed with an N.

The following tag setting options are available in a node’s right-click menu.

  • No Tag: Remove the current colored tag.
  • Tag Node Green: Set the node tag to green.
  • Tag Node Blue: Set the node tag to blue.
  • Tag Node Yellow: Set the node tag to yellow.
  • Tag Node Red: Set the node tag to red.

The screenshot below shows a project that has nodes with color tags, user-annotated tags and user-annotated color tags.

Project with Node Tags